Changes in Sibelius 5.2.5

The version number of Sibelius 5.2.5 is Sibelius 5.2.5 build 37. (Last updated 8 September 2008.)

Chord diagrams

= Sibelius no longer sometimes shows an incorrect chord symbol (from a different chord diagram) when
creating a new chord diagram based on an existing one.

Edit Noteheads

= Sibelius no longer allows you to attempt to delete a notehead type if it is not the last notehead type listed in

the dialog.
Edit Text Styles
= It is now possible to delete multiple user-defined text styles in a single operation in House Style » Edit Text
Styles.

= If you have a staff, system or lyric text object selected when you choose House Style » Edit Text Styles, the
text style of the selected text object is chosen for you automatically in the list. (This does not work for certain
special kinds of text, such as instrument names and rehearsal marks.)

Exporting graphics
= Sibelius no longer incorrectly adjusts the zoom and dots per inch values when returning to the File » Export»

Graphics dialog having already exported graphics since Sibelius was started; this has the effect that the Use
smallest bounding box now respects its state correctly for all EPS graphics exported.

Flexi-time

= Sibelius no longer crashes if you input into an unpitched percussion staff (e.g. a drum kit) using Flexi-time,
then undo, and input into that staff again.

Input devices

= If you have an M-Audio KeyStudio 49i or Sono 49, you should choose the KeyStudio 49i input map on the
Input Devices page of Preferences so that the Piano volume knob on your keyboard adjusts the master
volume fader in the Mixer and not the volume of one of the staves in the score, chosen at random.

Instrument changes

*  When creating an instrument change in a localised language version of Sibelius, the instrument change name
and warning now use localised instrument names where possible.

House styles

* When importing a house style, Sibelius now checks to see whether an incoming user-defined style matches
by name to an existing user-defined style in the score, and if it does, Sibelius replaces the existing user-
defined style with the incoming one (provided they are compatible, e.g. both are staff-attached).

* When importing notehead types that have the same appearance as an existing notehead type, Sibelius now
correctly fixes up any references to the duplicate notehead type in unpitched percussion instrument types to
use the existing notehead type.

= Sibelius no longer crashes if you undo after importing a house style.
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Lyrics

The text styles in the Create » Text » Lyrics submenu are now correctly updated when switching between
open scores (Mac only).

Create» Text» Lyrics » From Text File now appears correctly in all localised language versions of Sibelius.

V77 s

A number of errors in the automatic hyphenation for English words (e.g. “deepest”, “marching”, “impede”,
“birthright”, “virtues”) have been corrected.

ManuScript language

If the execution of a plug-in fails for some reason (e.g. a variable not found), Sibelius now displays the plug-
in editor rather than failing silently or, under some circumstances, crashing.

NoteRest.Transpose () and Selection.Transpose() now allow you to pass a diatonic interval to
specify the transposition.

New WrittenDiatonicPitch variable for Note objects, returning the written diatonic pitch.
AddInstrumentChange() now returns the InstrumentChange object created.

The SelectPassage() method has been improved such that items that attach to the starts of bars (e.g.

instrument changes) are now included in the selection if the whole bar is selected.

A problem whereby chord diagrams could not be deleted via ManuScript has been fixed.

Menus and shortcuts

For recent model MacBook and MacBook Pro computers that no longer have an embedded numeric keypad
in the main keyboard, a new Notebook (laptop) features keyboard shortcut set has been added to make it
possible to access Sibelius’s Keypad functions via the keyboard. To use this shortcut set, choose Sibelius 5»
Preferences, go to the Menus and Shortcuts page, and choose Notebook (laptop) features from the
menu. In this feature set, the keys 0-9 above the QWERTY keys now choose the corresponding function on
the on-screen Keypad. To add an interval above the selected note, type Shift-2-9; it is not possible to add an
interval below the selected note using keyboard shortcuts when Notebook (laptop) features is chosen.

Mixer

To reset the sound used by all staves in your score (useful if you want to reset playback settings for your
score back to their default), expand one of the staff strips (by clicking the triangle to the next of the
instrument name), then hold Shift and click the lower menu: a menu with a single item, (Auto), will appear:
choose this to reset the sound setting for all staves in your score.

To reset the device used by all staves in your score, expand one of the staff strips, then hold Shift and click
the upper menu: a menu showing all of the active devices in your playback configuration, plus the special
item (Auto), will appear: choose (Auto) to reset all your staves back to automatic device allocation, which is
strongly recommended. (You can also choose to set all staves in your score to play back through a specific

device from this menu, but this is not recommended in most circumstances.)

When Display is set to Program names (on the Playback page of Preferences), the program number
appended to the name of the patch in the sound choice menu now correctly reflects whether the sound set
counts programs from 0 or 1.

When Display is set to Program names (on the Playback page of Preferences), if the sound used to play
back a staff is not the sound requested (e.g. because the instrument definition requests a sound that is not
included in the current sound set), Sibelius now displays the program name of the sound being used, rather
than nothing.
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The Mixer now displays the sound name or sound ID of the first non-silent sound on a staff. This typically
occurs with ossia staves, where the ossia is not present at the start of the score; as a consequence, the staff
uses the No instrument (hidden) instrument type and hence has no playback sound.

Note input

When using Kontakt Player 2 for playback and inputting very short notes in step-time, notes played as they
are input would hang forever; this problem has now been fixed.

When using Sibelius Sounds Essentials for playback, some General MIDI sounds would not play back
during input until after you had played back the score at least once; this problem has now been fixed.

When Play notes as you edit is switched on, Sibelius will always play the appropriate sound when a note
is input or selected, even if the staff to which the note belongs is muted in the Mixer.

Page numbers

Edit» Go To Page now works correctly in the Japanese language version of Sibelius.

Playback

Adding an articulation, slur, or some other markings no longer causes the playback sound to be incorrect or
causes playback to be silent until the score is closed and reopened.

The message box that appears when the score you are opening uses a different configuration to the one you
currently have chosen now correctly responds both to the Don’t say this again checkbox on the message
box itself. See also Preferences below.

The log file created by Sibelius’s audio engine is no longer zero bytes, making it possible to send it to our
technical support team for diagnostic purposes (Windows only).

Starting playback in the bar following a “mute” instruction no longer sometimes results in Sibelius playing
the wrong sound.

Unmeasured tremolos on tied notes now play back correctly.

A problem whereby Sibelius would not choose the correct sound if it had to change slot or channel from one
patch with switches providing multiple sounds to another slot or channel with switches has now been fixed.

If you add an ossia staff to a multi-staff instrument (e.g. piano), Sibelius no longer plays the wrong sound
both for the ossia staff and for the staff of the multi-staff instrument above or below which the ossia is
positioned.

Notes whose start positions are offset by Rubato (set in Play » Performance) or Live Playback data to which
articulations, symbols, lines or text are attached that give rise to sound ID changes now play back correctly,
with the sound ID change affecting the correct note(s).

A relative sound ID change (e.g. +mute) that requires Sibelius to switch to another channel or slot in order to
find the sound that matches exactly is now correctly preferred over playing a sound that does not exactly
match but which is available on the same slot or channel. This means that Sibelius is more likely to choose
the correct sound, but it does also mean that in some scores Sibelius may now use some different sounds
than it did in previous versions.

If a switch in a sound set specified the adding of more than one sound ID element (e.g. +mute +legato),
Sibelius would previously not switch to the correct sound in all cases. This problem has now been fixed.

Switching to a sound ID that requires a new slot or channel and is more than just one element away from the
current sound ID now works as expected.
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A problem whereby Sibelius would not consider instrument changes on a staff when determining which
staves should be shared on the same MIDI channel (when more sounds are required to play the score than
there are available channels) has been fixed.

Sibelius is now able to correctly issue the appropriate reset keyswitch notes when the playback configuration
uses a manual sound set with a MIDI-type sound set file.

Playback dictionary

A problem whereby the Until start of next note and Until end of next note options for sound ID changes
arising from staff text objects would actually apply to one note too many has been fixed.

Plug-ins

The plug-ins in the Plug-ins » Batch Processing folder now work correctly with folder and file names
containing Japanese characters (Mac only).

Plug-ins » Composing Tools » Pitch Mapping now correctly retains the Live Playback data, slide and
bracket properties of notes.

Plug-ins » Notes and Rests » Double Note Values and Halve Note Values no longer fail if they encounter
tuplets in multiple voices.

Plug-ins » Text» Number Bars now works correctly in localised language versions of Sibelius.

Preferences

The Warn if configuration used in score is different to the active configuration checkbox on the Other
page of Preferences has been removed. It has been replaced by a new group of radio buttons on the
Playback page of Preferences. By default, Sibelius is set to Let me choose whether to change to the new
configuration, such that when you open a score that uses a different playback configuration, you are
prompted whether or not to load the new playback configuration. You can alternatively choose Always
change to the new configuration or Never change to the new configuration.

If you have Let me choose whether to change to the new configuration chosen, and then switch on the
Don’t say this again checkbox in the message box that appears when you open a score, Sibelius will update
your choice in Preferences: if you click Yes and switch on Don’t say this again, Sibelius will choose
Always change to the new configuration; if you click No and switch on Don’t say this again, Sibelius will
choose Never change to the new configuration.

If you have Restore score window sizes and positions switched on (on the Files page of Preferences)
and leave a score window maximised on a secondary display that is no longer connected to your computer
when you next open the score, the score window is now correctly repositioned on the primary display,
rather than opening up completely out of view (Mac only).

Printing

Remaining problems with booklet printing with scores where the first page number is not 1 have been fixed.

Selections and passages

Remaining problems with duplicate instrument styles being created when copying and pasting music from
and to staves using user-defined instrument types have been fixed.
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Sound sets

* The sound sets for Tapspace Virtual Drumline, Vienna Symphonic Library Special Edition, Garritan Jazz and
Big Band, Sibelius Sounds Choral and Sibelius Sounds Essentials have been updated.



